Ошибка инсталяции openvpn на ubuntu 12.04

Дата: Август 23, 2016 - 4:38 дп Нет комментариев

Доброе время суток.

Мне понадобилось установить openvpn на одном из серверов. но при инсталяции я получал ошибку:

 6502acme |  copy code |? 
01
oot@oms:~# apt-get install openvpn
02
Чтение списков пакетов… Готово
03
Построение дерева зависимостей       
04
Чтение информации о состоянии… Готово
05
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
06
Пакеты, имеющие неудовлетворённые зависимости:
07
 libsnmp15 : Зависит: libsnmp-base (>= 5.4.3~dfsg-2.5ubuntu1) но он не будет установлен
08
             Зависит: libperl5.14 (>= 5.14.2) но он не будет установлен
09
 openvpn : Зависит: liblzo2-2 но он не будет установлен
10
           Зависит: libpkcs11-helper1 (>= 1.05) но он не будет установлен
11
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

В интернете я не нашел решения (может плохо искал), пришлось решать проблему самому… решение под катом.

Когда APT выдает такую ошибку, он собственно и подсказывает что нужно сделать…

apt-get -f install

при этом он пытается решить проблемы и в данном конкретном случае – он предлагает удалить два пакета: libsnmp15 snmpd.

Если они у Вас используются, то нужно заказать окно и провести их деинсталяцию, и только после этого можно будет установить openvpn.

После инсталяции openvpn можно поставить snmpd, который засобой притянет libsnmp15.

 

Может быть есть другое решение? Если знаете – буду рад если подскажете. :)

Оставить комментарий